
Guide to Using the Demonstration Version of

SchoolTime

PMB 200
2397 NW Kings Blvd.
Corvallis, OR 97330

Quality Software With Your Needs In Mind

Toll-Free:  (888) 349-6627
Oregon:  (541) 752-3051

Fax:  (541) 752-6804
E-Mail:  schooltime@dixoncreek.com





Guide to Using the Demonstration Version of SchoolTime Contents  ••   iii

Contents

Overview 1

Introduction ...............................................................................................................................................1
What is SchoolTime...?.............................................................................................................................1
Dixon Creek Software................................................................................................................................2

Who Are We..............................................................................................................................2

Getting Started 3

Getting Started Overview.........................................................................................................................3
Installation/Setup......................................................................................................................................3
Now What Do I Do...? ..............................................................................................................................4

1.) Lists Setup ............................................................................................................................4
2.) Faculty Setup........................................................................................................................6
3.) Course List Setup.................................................................................................................7
4.) Course Sections Setup........................................................................................................7
5.) Student Setup.......................................................................................................................8

Technical Specifications 11

System Requirements .............................................................................................................................11

Contacting Support 13

How To Get In Touch With Us .............................................................................................................13
SchoolTime Support Program................................................................................................................13

How to Use Help 15

Online Help...............................................................................................................................................15





Guide to Using the Demonstration Version of SchoolTime Overview  ••   1

Overview

Introduction

Welcome to the User’s Guide for the Demonstration Version of
SchoolTime.  This document will assist you in getting started and previewing
the many useful features available in the full version of SchoolTime.

The Demonstration Version of SchoolTime allows you to enter a limited
amount of information, with restrictions on the number of records allowed in
the Students, Faculty, Courses and Financial Screens.  In addition, the
security system has been disabled, although you can view the interface and
read about it in the online documentation.  Though this printed guide is a
smaller version of the full system documentation, the demonstration version
does contain the complete online help system so you can see text
descriptions of all SchoolTime’s features.

What is SchoolTime...?

SchoolTime is a Windows-based computer program designed with the
needs of a school in mind.  It keeps track of school information, allowing it
to be easily stored and manipulated.  SchoolTime will take your old student,
instructor and course records and breath new life into them, allowing you to
use that information to work more efficiently.
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SchoolTime runs under both Windows 3.1 and Windows 95, which are the
industry standard in computer platforms.  As such, SchoolTime runs like
your word processor, spreadsheet and other Windows applications.  For
those with Windows experience, SchoolTime will look very familiar, and the
ease of using Windows also allows new users to learn SchoolTime in a
short period of time.

Dixon Creek Software

Who Are We

Dixon Creek Software is a small company focused on the needs of the
individual client.  Specializing in full-service PC-based computer application
development, Dixon Creek Software provides assistance in not only
application construction, but also systems analysis, installation and support.
Our goal is to produce software that suits our client’s needs.  We want our
clients to be satisfied with the software well after final delivery.  End-user
support is very important at Dixon Creek Software and we make every
attempt to see that our clients are as happy as possible.
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Getting Started

Getting Started Overview

This section of the guide will help get you started in using SchoolTime.  It
describes the procedures and requirements for installing the software, along
with step-by-step for initial configuration and setup.

Installation/Setup

SchoolTime requires the following hardware and software:

• Windows 3.1 - 3.11 or Windows 95

• 8 MB RAM minimum (16 MB recommended)

• 20 MB of available hard disk space

• VGA (256 color) or better recommended

Be certain that your machine meets the above criteria.  Items marked as
recommended will make SchoolTime run more efficiently or improve its
appearance, but SchoolTime will run fine with the minimum requirements.

To install SchoolTime:

1. Start Windows, if it is not already running.

2. Insert SchoolTime Disk 1 into drive a: or b:
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3. Choose Run from the File menu.

4. Type a:\setup.exe (where a: indicates your floppy drive), and
click OK.

5. Follow the Setup instructions on the screen.

By default, the installation will create a folder titled SchoolTime .  If you did
not change this option during Setup, that folder will be created during
installation.

Please Note: Before beginning, be certain that you have enough disk space
for SchoolTime’s installation.  The Demonstration Version is a full running
version of SchoolTime (with restrictions previously noted).  It requires a
minimum of 20 MB of free space.

Now What Do I Do...?

SchoolTime is a program with many different features, so when you first
begin there are several steps which should be taken to ensure a minimum of
problems.

It is highly recommended that you perform all these steps, in this order, to
prepare SchoolTime for use.

1.) Lists Setup

Within SchoolTime are a variety of lists which will not change frequently,
but may vary from school to school or year to year.  These are contained
on the Lists Screen of SchoolTime.  We suggest that you begin by entering
the lists which you will be using.  You can reach the Lists Screen by clicking
the “Lists” button on the Main Screen.

To change information on one of the lists (The Demonstration Version of
SchoolTime comes with a default set of lists already entered) you simply
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place the mouse over the entry you wish to change and click.  This will
place a cursor on the entry, and you can add and delete text as you wish.

Entire rows can also be deleted from the list by clicking the gray box to the
left of a row and pressing DEL on the keyboard.  You will be asked
whether you wish to delete that list item.  If you click Yes, the row will be
deleted, clicking No will return you to the list without changing anything.

Please Note: Deleting list items in SchoolTime is permanent - there is no
undo or undelete function.  As such, be certain you wish to delete a row
before doing so.

The various lists are as follows:

• Class Periods:  Here you enter the class period (which can be
either text, numbers or a combination of the two) and the time
slot during which the period occurs.

• Course Categories:  Here you enter the course categories which
your school offers.  Categories include broad subjects of study,
such as English, math, science and foreign languages.

 Please Note:  Course categories are used to define graduation
requirements.  As such, if you require a specific English course
to be taken each year, and also have a writing course which
cannot count toward graduation, it is recommended that the
writing course be assigned its own course category.

• Grades & GPA:  Here you enter the letter grading scale and
corresponding percentages and GPA weights which will be
used throughout SchoolTime.

• Attendance Codes:  Here you enter attendance codes to note
different types of absences and tardies.  These include a code
for use in the program and a description of the violation it
represents.

• Sports & Activities: Here you enter the sports and other
activities in which students may participate.  In the upper grid
you enter the name of the sport and chose a season from the
combo box beside it.  Highlighting one of these rows by clicking
on it will display the coach/advisor information in the grid on the
bottom of the screen.  You may enter that information directly
as well.
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 Please Note:  Only one coach/advisor can be checked as the
Primary and that coach/advisor will be shown throughout the
system when brief mention is made of the sport.

• Classrooms:  Here you enter information on the classrooms at
your school, including classroom IDs, and room capacities.  At
this time you do not have any faculty members entered, so leave
the Primary Instructor space blank.

• Transaction Types:  Here you enter the different types of
transactions which you wish to make note of in the Financial
Screen of SchoolTime.  This can include such things as
payments, tuition charges and other fees.

• Graduation Requirements:  Here you enter the graduation
requirements for different classes.  In the years grid you must
enter the years which you will be filling in requirements for.
Highlighting one of the years you have entered will allow you to
edit the requirements for that year in the grid on the bottom of
the screen.  Clicking the College-prep check box will switch the
requirements shown from college-prep to non-college-prep,
which are two entirely independent lists. Both must be entered
separately if you wish to use that feature.

2.) Faculty Setup

At this point it is suggested that you enter your faculty information.  This is
done from the Faculty Screen, which can be reached by clicking the Faculty
Button on the Main Screen.  If you are on another screen, the Faculty
Screen can also be reached by clicking the button on the toolbar which
looks like an apple.

From the File menu, chose “Add A New Instructor.”  This will open a
screen where you enter the first, middle and last name of the new instructor.
When these are entered, click OK and you will be returned to the Faculty
Screen, where on the Main Tab the new instructor’s information is shown.
You may now enter the rest of the information for the new instructor.
Repeat those steps until you have entered at least the name for every
instructor at your school.

If no faculty records have been entered, SchoolTime automatically adds one
called First Instructor.  After adding your instructors, you may delete this
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record.  To do so, click on the down-arrow on the right hand side of the
Instructor’s Full Name combo box and click on First Instructor in the list
that opens.  Then go to the File menu, and chose Delete Current Instructor.
This will prompt you as to whether you wish to delete the Instructor.  Click
Yes.

At this point, you can enter the primary instructor on the classrooms in the
Lists Screen.  To go to the Lists Screen, click on the button on the toolbar
that looks like a piece of paper with light-blue lines on it.

3.) Course List Setup

At this point it is suggested that you enter your offered course information.
A course in SchoolTime is a generic class, such as ENG 101.  No period
or instructor is attached to a course - an actual offering of a course is called
a section. Courses are added on the Course List Tab of the Course
Screen.  To get there, click on the Courses Button on the Main Screen or
from another screen click the button on the toolbar with two stacked books
on it.  When the screen comes up, click the tab which is labeled “Course
List.”

The Course List Tab is formatted like many of the screens in SchoolTime.
It consists of a grid with Add, Edit and Delete buttons on the bottom of the
screen within a frame.  This grid, unlike those in the Lists Screen, cannot be
edited directly by clicking on it.  Clicking will, however, highlight the row.

To put your courses into SchoolTime, click the Add button.  The Add
Course Screen will come up, and you may enter the information there.

If you entered information incorrectly when adding a new course, click on
that course’s row to highlight it.  Then click the Edit button on the bottom of
the screen.  Changes can then be made to the information you entered.

4.) Course Sections Setup

You now need to enter information on the specific course sections which
are being offered.  An example of a course section would be ENG 101,
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taught during 1st period by Joe Smith in room C4.  Course sections can be
entered on the Course Sections Tab on the Courses Screen.  If you are not
on the Courses Screen, you can reach it by clicking the Courses Button on
the Main Screen or from another screen clicking the button on the toolbar
with two stacked books from anywhere in SchoolTime.  Once on the
Courses Screen, click on the tab which reads “Course Sections.”

The Course Sections Tab is formatted very similarly to the Course List Tab.
You may highlight rows on the grid by clicking on them.  The information on
the Course Sections Grid cannot be edited directly on the grid.

To enter a course section, click the Add button on the bottom of the screen.
This will take you to the Add Course Section Screen, where you actually
enter the information, as you did on the Course List Screen.

If you entered information incorrectly when adding a new section, click on
that section’s row to highlight it.  Then click the Edit button on the bottom of
the screen.  Changes can then be made to the information you entered.

5.) Student Setup

At this point it is suggested that you enter the student information for your
school.  This is done from the Students Screen, which can be reached by
clicking the Student Button on the Main Screen.  If you are on another
screen, the Students Screen can also be reached by clicking the button on
the toolbar which looks like a face.

From the File menu, chose “Add A New Student.”  This will open a screen
which will prompt you for the first, middle and last name of the new student.
When these are entered, click OK and you will be returned to the Student
Screen, where on the Main Tab the new student’s information is shown.
You may now enter the rest of the information for the new student.  Repeat
those steps until you have entered at least the name for every student at
your school.

If no student records have been entered, SchoolTime automatically adds
one called “First Student.”  After adding your students, you may delete this
record.  To do so, click on the down-arrow on the right hand side of the
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Student’s Full Name combo box and click on First Student in the list that
opens.  Then go to the File menu, and chose Delete Current Student.  This
will prompt you as to whether you wish to delete the Student.  Click Yes.

When these steps are completed, you will be well on your way to having
your information entered into SchoolTime, and having it configured how you
want.  After this time, you can enter student and faculty schedules, financial
records, calendar events and all the other information that SchoolTime
provides access to.
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Technical Specifications

System Requirements
• Windows 3.1 - 3.11 or Windows 95

• 8 MB RAM minimum (16 MB recommended)

• 30 MB of available hard disk space

• VGA (256 color) or better recommended

Networks: SchoolTime has been thoroughly tested using Novell v3.12, but
should also work with the following network operating systems:

• Windows for Workgroups 3.11

• Novell v3.1 or better

• Windows NT v3.5 or better

• LANtastic peer-to-peer network

Regular backups of your critical data is essential.  Although SchoolTime
does not provide a backup function we strongly recommend that you
purchase a suitable backup device such as a tape backup unit, or one of the
many popular high-capacity removable disks.
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Contacting Support

How To Get In Touch With Us
Dixon Creek Software’s regular office hours are Monday through Friday
8:30 AM to 5:00 PM Pacific Time.  We can be reached in the following
manners:

Toll-free: (888) 349-6627

Oregon: (541) 752-3051

Fax: (541) 752-6804

E-mail: schooltime@dixoncreek.com

Mailing Address: PMB 200
2397 NW Kings Blvd.
Corvallis, OR 97330

SchoolTime Support Program

From time to time problems come up that require assistance from our
technical staff.  We at Dixon Creek Software strive to provide the highest
quality user support available.  We are always more than happy to supply
you with helpful, friendly and courteous answers to all your computer
questions.

The purchase of your SchoolTime product entitles you to one full year of
free technical support as well as all maintenance updates during that period
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of time. You will also receive special notification of new SchoolTime
products and upgrades as they become available. Additional annual support
agreements may be purchased from Dixon Creek Software and will provide
the same technical support, maintenance updates and other benefits that you
received during the first year.
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How to Use Help

Online Help
The Demonstration Version of SchoolTime provides the complete text of
the full SchoolTime manual in an online format.  You can access that
information from the Help menu on most screens, the Help button on the
toolbar or a Help button on most add/edit screens.

To view the information on how to use the help file, run SchoolTime and
from the Help menu on the Main Screen, chose Contents.  After the help
file loads, click on the Help menu there, and from the list chose How to Use
Help.  Information can also be obtained from your Windows
documentation.
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This manual was produced using Doc-To-Help®, by WexTech Systems, Inc. 


